Der Bloonix Satellite wurde unter der GPLv3 lizensiert

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Der Bloonix Satellite wurde unter der GPLv3 lizensiert

      Hallo zusammen,

      kurz und bündig:

      blog.bloonix.org/ueberwachung-…obus-jetzt-opensource-61/

      Die Doku zum Satellite kommt in den nächsten Tagen :)

      Wer dennoch vorab schonmal damit rumspielen möchte, muss folgendes machen...

      Der Agent, der bei Euch die Remote-Checks ausführt, muss um folgende Konfiguration erweitert werden:

      Source Code

      1. satellite {
      2. ssl_verify_mode none
      3. ssl_ca_path /etc/ssl/certs
      4. authkey ein-sehr-sehr-langer-authkey
      5. }


      Die SSL-Parameter sollten Euch ja schon geläufig sein :)

      Auf jedem Server, auf dem Ihr nun den Bloonix-Satellite installiert, müsst Ihr den Authkey eintragen. Dazu muss der Server, auf dem der Satellite läuft, in der WebGUI unter ADMINISTRATION -> Locations angelegt werden. Wenn Ihr dann zum Beispiel einen HTTP-Check anlegt, könnt Ihr auswählen, von welchem Satellite der Check ausgeführt werden soll.

      Viele Grüße
      Jonny


      Nachtrag: die Dokumentation gibt es hier: bloonix.org/de/docs/howtos/how…ng-bloonix-satellite.html
    • Also, zum testen habe ich mir erst mal eine Debian 8 VM angelegt. Dort habe ich die Paket "bloonix-satellite bloonix-plugins-basic bloonix-plugins-linux" installiert.
      Danach habe ich auf meinem bloonix Server, den Teil, den Du oben geschrieben hast, in der Konfiguration vom Agent hinzugefügt und die neue VM unter "ADMINISTRATION -> Locations" hinzugefügt.

      Nun hört es bei mir auf und ich bin etwas verwirrt. Wenn ich einen Server unter Locations hinzufügen, warum kann ich dann bei den Checks, z.B. HTTP-Check, nur noch die Server auswählen, die ich auch unter Locations hinzufügen, aber den eigentlichen Agent, der vorher die Remote Checks ausgeführt hat, nicht mehr? Muss ich auf dem Server dann ebenfalls den Bloonix Satellite installieren?

      Ich vermute mal, den authkey, den ich vorher am Agent definiert habe, muss ich beim satellite in die main.conf eintragen?
      Muss auf die VM, wo der Bloonix Satellite drauf läuft, auch der Agent eingerichtet und in der WebGUI hinzugefügt werden?

      Wenn ich dann einfach mal ein Check Umstelle auf mehrere Messpunkte, erhalte ich folgenden Status bei der Prüfung: "Missing mandatory option 'locations'"
      Viele Grüße
      Marvin

      The post was edited 1 time, last by NevaKee ().

    • NevaKee wrote:

      Nun hört es bei mir auf und ich bin etwas verwirrt. Wenn ich einen Server unter Locations hinzufügen, warum kann ich dann bei den Checks, z.B. HTTP-Check, nur noch die Server auswählen, die ich auch unter Locations hinzufügen, aber den eigentlichen Agent, der vorher die Remote Checks ausgeführt hat, nicht mehr? Muss ich auf dem Server dann ebenfalls den Bloonix Satellite installieren?


      Es gibt 4 Möglichkeiten: Default, Failover, Rotate, Multiple

      Default heißt, dass der Agent verwendet wird, der die Remote-Checks ausführt. Das wäre also so, als wäre keine Locations eingerichtet.

      Failover, Rotate und Multiple heißt, dass der Agent, der die Remote-Checks ausführt, die Checks zu den Satellites weiterleitet und den Check nicht selbst ausführt.

      Alles klar? :)


      Ich vermute mal, den authkey, den ich vorher am Agent definiert habe, muss ich beim satellite in die main.conf eintragen?


      Korrekt.


      Muss auf die VM, wo der Bloonix Satellite drauf läuft, auch der Agent eingerichtet und in der WebGUI hinzugefügt werden?


      Man fügt keine Agenten in die WebGUI ein. Wenn du den Server, auf dem der Satellite läuft, überwachen möchtest (CPU etc.), dann kannst du den Agenten dort installieren und einrichten, so wie du es für jeden anderen Server machen würdest.


      Wenn ich dann einfach mal ein Check Umstelle auf mehrere Messpunkte, erhalte ich folgenden Status bei der Prüfung: "Missing mandatory option 'locations'"


      Dann hast du wahrscheinlich das Paket bloonix-server nicht aktualisiert.

      VG
      Jonny
    • Jonny wrote:

      sind denn sonst alle anderen Komponenten auf dem aktuellsten Stand? Sprich bloonix-server, bloonix-webgui etc.?

      Source Code

      1. ~ # dpkg -l | grep bloonix
      2. ii bloonix-agent 0.53-1 all Bloonix agent daemon
      3. ii bloonix-core 0.19-1 all Bloonix core modules
      4. ii bloonix-dbi 0.5-1 all Bloonix database interface.
      5. ii bloonix-fcgi 0.7-1 all Bloonix FastCGI wrapper
      6. ii bloonix-heaven 0.10-1 all Bloonix web framework
      7. ii bloonix-plugin-config 0.18-1 all Bloonix Plugin Configuration Files
      8. ii bloonix-plugins-apache 0.11-1 all Bloonix Plugins Apache
      9. ii bloonix-plugins-basic 0.36-1 all Bloonix Plugins Base
      10. ii bloonix-plugins-linux 0.30-1 all Bloonix Plugins for Linux
      11. ii bloonix-plugins-nginx 0.8-1 all Bloonix Plugins Nginx
      12. ii bloonix-server 0.25-1 all Bloonix server daemon
      13. ii bloonix-webgui 0.43-1 all Bloonix WebGUI
      14. ii bloonix-webgui-core 0.12-1 all Bloonix WebGUI core packages
      Display All



      Jonny wrote:


      Es gibt 4 Möglichkeiten: Default, Failover, Rotate, Multiple

      Default heißt, dass der Agent verwendet wird, der die Remote-Checks ausführt. Das wäre also so, als wäre keine Locations eingerichtet.

      Failover, Rotate und Multiple heißt, dass der Agent, der die Remote-Checks ausführt, die Checks zu den Satellites weiterleitet und den Check nicht selbst ausführt.

      Alles klar? :)


      Schon klar, aber warum kann ich den normalen Agent, der die Checks bei Default ausführt, nicht auch bei Failover, Rotate, Multiple verwenden?

      Jonny wrote:


      Dann hast du wahrscheinlich das Paket bloonix-server nicht aktualisiert.

      Siehe weiter oben. ;)
      Viele Grüße
      Marvin
    • Hallo,


      Erstmal ein dickes Lob an Jonny =) Darauf haben wir lange gewartet.

      Mal eine kleine Nachfrage. Woher bzw wie wurde der Authkey definiert? Habe keine Ahnung woher ich den beziehen soll.

      Bei uns kommt nun auch die Fehlermeldung : Missing mandatory option 'locations' *erledigt*

      Neuer Fehler : Acces denied :D

      Gruss

      The post was edited 2 times, last by Tronier ().

    • Kleiner Nachtrag:

      Den Authkey kannst du wie ein Passwort betrachten. Der Satellite lauscht halt auf Port 5464 und ist - wenn man iptables nicht konfiguriert hat - für die Welt offen. Aus diesem Grund gibt es den Authkey. Nur wer sich mit dem Authkey authentifizieren kann, darf über den Satellite Checks ausführen. Das ist der Grund, weshalb der Authkey auch in der Konfiguration des Agenten eingetragen werden muss, denn so kann sich der Agent bei den Satellites authentifizieren.

      Man könnte natürlich auch via SSL (CA+Cert+Key) eine sichere Authentifizierung hinbekommen, aber der Authkey ist halt deutlich einfacher.
    • Jonny wrote:

      Den Authkey trägst du dann in die Konfigurationsdatei jedes Satellites und in die Konfiguration des Agenten ein, der die Remote-Checks ausführt.


      Hi Jonny,
      jedes Agenten? Also auf jedem Satellite? Weil ich hab nun das Problem "location is not online"!
      Sorry Frage Überflüssig ... habe nicht richtig gelesen... in dem der Remote-Checks ausführt ist der Eintrag ebenfalls drin. Problem bleibt leider dennoch!

      The post was edited 1 time, last by PhiGi ().

    • Hi Philip,

      natürlich nicht auf "jedem" Agenten :)

      Bitte lies dir folgendes Dokument durch und versuche zu verstehen, was der "Remote-Agent" ist bzw. macht:

      bloonix.org/de/docs/faq/how-do…r-hosts-and-services.html

      Schau, du hast vermutlich den Agenten auf jedem Server installiert, auf dem die Systemvitals überwacht werden sollen. Du hast aber nur einen einzigen Agenten, der die Remote-Checks ausführt (HTTP, Ping, etc.). Nur diese eine Agent erhält den Authkey, da dieser Agent die Checks zu den Satellites weiterreicht.

      VG
      Jonny
    • Hi Jonny,

      ja ich hab mein Beitrag noch fix Editiert "habe nicht richtig gelesen" ;)

      Dann hatte ich es Richtig gemacht und dennoch den Fehler bekommen "is not online". Problem scheine ich nun aber gelöst zu haben, der Satellite hat von mit noch die Plugins Installiert bekommen und schon lief es, denn laut Log konnte er nur den Check nicht ausführen. Ich hatte es nicht so verstanden das die Plugins mit Installiert werden müssen.

      Gruß,
      Phil
    • Supi, freut mich das du es hinbekommen hast :)

      Der Satellite macht das, was der Agent macht: den Check (Plugin) ausführen. Sobald für einen Service in der WebGUI eine Location konfiguriert ist, werden die Checks zu den Satellites weitergereicht. Der Agent agiert an der Stelle nur noch als Vermittler zwischen Server und Satellites :)
    • Ja freut mich auch :P

      Letzes Problem: ich hab auf einem vServer CentOS weil Debian nicht Angeboten wird. Dort hab ich einen Satellite Installiert. Dieser Funktioniert auch soweit, nur HTTP Check nicht, es steht nur "Status Informationen https". Woran kann es liegen? An CentOS? Alle anderen 4 Satelliten laufen auf Debian sowie auch der Server+WebGUI.

      Hinweis: Wenn ein Satellite neu Online ist und im GUI Hinzugefügt wurde, dringend ein service bloonix-server restart sonst wird der neue Satellite zwar im GUI Angezeigt und kann Eingebunden werden, allerdings führt er keine Checks durch!

      The post was edited 1 time, last by PhiGi ().

    • PhiGi wrote:

      Hinweis: Wenn ein Satellite neu Online ist und im GUI Hinzugefügt wurde, dringend ein service bloonix-server restart sonst wird der neue Satellite zwar im GUI Angezeigt und kann Eingebunden werden, allerdings führt er keine Checks durch!


      Das ist nicht nötig. Der Bloonix-Server cached die Locations für 30 Sekunden. Wenn du also eine neue Location anlegst, sollte der Server diese nach max. 30 Sekunden kennen.
    • Jonny wrote:

      Das ist nicht nötig. Der Bloonix-Server cached die Locations für 30 Sekunden. Wenn du also eine neue Location anlegst, sollte der Server diese nach max. 30 Sekunden kennen.


      Also ich habe es auch festgestellt, dass der server neu gestartet werden muss, damit die Location übernommen werden.
      Ansonsten funktioniert es bei mir mit dem Bloonix Satellite wunderbar.
      Viele Grüße
      Marvin